diff --git a/buildroot-v86/board/v86/rootfs_overlay/etc/profile.xrsh b/buildroot-v86/board/v86/rootfs_overlay/etc/profile.xrsh
index a13901d..03b098c 100644
--- a/buildroot-v86/board/v86/rootfs_overlay/etc/profile.xrsh
+++ b/buildroot-v86/board/v86/rootfs_overlay/etc/profile.xrsh
@@ -38,7 +38,7 @@ test -d /dev/browser || {
   }
 
   setup_overlayfs(){
-    test -f /mnt/overlayfs.zip && unzip /mnt/overlayfs.zip -d /
+    test -f /mnt/overlayfs.zip && ziprun /mnt/overlayfs.zip 
   }
 
   setup_incoming_cmds(){
diff --git a/buildroot-v86/board/v86/rootfs_overlay/root/hook.d/URI/fragment/exec.sh b/buildroot-v86/board/v86/rootfs_overlay/root/hook.d/URI/fragment/exec.sh
index 52d2aed..9e44db5 100755
--- a/buildroot-v86/board/v86/rootfs_overlay/root/hook.d/URI/fragment/exec.sh
+++ b/buildroot-v86/board/v86/rootfs_overlay/root/hook.d/URI/fragment/exec.sh
@@ -1,12 +1,13 @@
 #!/bin/sh
 source /etc/profile.sh # expose xrsh cmds like require etc
 
-if [[ "$1" =~ pos=|t= ]] then 
-  # we are dealing with XR or Media Fragments 
-  exit # ignore for now 
+if [[ "$1" =~ "pos=|t=" ]]; then 
+  # we are dealing with XR or Media Fragments  (ignore for now)
+  echo "[x] detected Media/XR Fragment in URI: $1"
 fi
 
 # otherwise execute
 echo "" # clear line
 $*      # simply execute
 echo "$*"  >> /tmp/frag.log
+
diff --git a/dist/v86-linux.iso b/dist/v86-linux.iso
index d5979d0..663efb6 100644
Binary files a/dist/v86-linux.iso and b/dist/v86-linux.iso differ
diff --git a/edit.sh b/edit.sh
index 145d7a5..fbbb389 100755
--- a/edit.sh
+++ b/edit.sh
@@ -1,11 +1,15 @@
 #!/bin/bash
 set -e
-make BR2_EXTERNAL=/buildroot-v86 v86_defconfig
+export BR2_EXTERNAL=/buildroot-v86 
+export BR2_PACKAGE_BUSYBOX_CONFIG=/buildroot-v86/configs/busybox.config 
+make v86_defconfig
 
 make menuconfig
 make busybox-menuconfig
 make linux-menuconfig
-make savedefconfig
+make savedefconfig          # /buildroot-v86/configs/v86_defconfig
 make linux-savedefconfig
+make linux-update-defconfig # /buildroot-v86/configs/linux.config
+make busybox-update-defconfig # /buildroot-v86/configs/linux.config
 
 make
diff --git a/nix/README.md b/nix/README.md
index b5fb590..1c531e0 100644
--- a/nix/README.md
+++ b/nix/README.md
@@ -14,7 +14,7 @@ hello: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), statically link
 # building a nixos pkg
 
 ```bash
-$ nix-build '<nixpkgs>' --pure -I nixpkgs=channel:nixos-24.05 -A pkgsCross.$ARCH.pkgsStatic.hello
+$ nix-build '<nixpkgs>' --pure -I nixpkgs=channel:nixos-24.05 -A pkgsCross.musl32.pkgsStatic.hello
 $ file hello
 hello: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), statically linked, not stripped
 ```
diff --git a/nix/build_nixpkg.sh b/nix/build_nixpkg.sh
index 133a7d8..e33eff4 100755
--- a/nix/build_nixpkg.sh
+++ b/nix/build_nixpkg.sh
@@ -3,6 +3,7 @@
 #test -n "$ARCH"    || ARCH=i686-embedded
 test -n "$ARCH"    || ARCH=musl32
 test -n "$CHANNEL" || CHANNEL=nixos-24.05 
-test -n "$1" || { echo "usage: [ARCH=...] [CHANNEL=...] build_nixpkg.sh <packagename>"; exit 0; }
-set -x
+test -n "$1" || { echo "usage: [ARCH=...] [CHANNEL=...] build_nixpkg.sh <packagename> [outfile]"; exit 0; }
+set -xe
 nix-build '<nixpkgs>' --pure -I nixpkgs=channel:$CHANNEL -A pkgsCross.$ARCH.pkgsStatic.$1
+test -n "$2" && cp result/bin/$1 $2
diff --git a/nix/hello.nix b/nix/hello.nix
index 06e69ae..efa7fde 100644
--- a/nix/hello.nix
+++ b/nix/hello.nix
@@ -5,8 +5,8 @@ in
 
 # callPackage is needed due to https://github.com/NixOS/nixpkgs/pull/126844
 pkgs.pkgsStatic.callPackage ({ mkShell, fuse, pkg-config, file }: mkShell {
-  # these tools run on the build platform, but are configured to target the host platform
-  nativeBuildInputs = [ pkg-config file ];
-  # libraries needed for the host platform
-  buildInputs = [ fuse ];
+  ## these tools run on the build platform, but are configured to target the host platform
+  #nativeBuildInputs = [ pkg-config file ];
+  ## libraries needed for the host platform
+  #buildInputs = [ fuse ];
 }) {}